On PHP Version Requirements


Anthony Ferrara (ircmaxell):

I learned something rather disturbing yesterday. CodeIgniter 3.0 will support PHP 5.2. To put that in context, there hasn’t been a supported or secure version of PHP 5.2 since January, 2011. That’s nearly 4 years. To me, that’s beyond irresponsible… It’s negligent…

That’s worrying indeed. WordPress for example still runs on PHP 5.1. The argument that 72% of WordPress installs still run on servers running 5.2/5.3 is just wrong. As Anthony correctly points out:

Another very significant variable are the hosts themselves. They are driven by demand and by market forces just like anything else.

If major projects like WordPress and CodeIgniter say that “5.2 will no longer be supported”, the vast majority of hosts would almost immediately support newer versions.


The project sets the requirements, and the hosts fulfil them.

In all PHP projects I create a minimum of PHP 5.5 is required. If it’s a project for a client, this version requirement is also mentioned in the contract signed. PHP 5.4 will also do: the only thing I miss in 5.4 from 5.5 is the new password hashing API, which can be polyfilled.

On PHP Version Requirements →

Published by Bramus!

Bramus is a frontend web developer from Belgium, working as a Chrome Developer Relations Engineer at Google. From the moment he discovered view-source at the age of 14 (way back in 1997), he fell in love with the web and has been tinkering with it ever since (more …)

Leave a comment

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.